Compatibility Issues in Maple 2017 - Maple Programming Help

Online Help

All Products    Maple    MapleSim


Home : Support : Online Help : System : Information : Updates : Maple 2017 : updates/Maple2017/compatibility

Compatibility Issues in Maple 2017

The following is a brief description of the compatibility issues that affect users upgrading from Maple 2016 to Maple 2017.

 

Extended Typesetting by Default

MapleCloud Palette

The hypergeometric function

Number Theory

GraphTheory Graphs

IntegerRelations

Importing from Excel

The plottools:-semitorus Command

The convert/units Command

Change of Error Message When Accessing Nonexistent Record Fields

Change in Code Edit Region Properties

Supported Video File Formats

Pasting Windows Filenames into Worksheets

Extended Typesetting by Default

The default typesetting level is now extended. In most situations, you will not notice any difference in the output. The most significant differences are described below. If you prefer to use the Standard typesetting level, set this via the Options Dialog or with the interface(typesetting=standard) command.

• 

In earlier versions of Maple, using extended typesetting resulted in a typeset mathematical display of special functions. For example, the BesselJ function would be represented as an italic J. In Maple 2017, the default extended typesetting display for special functions is the command name itself; this is consistent with the default Maple 2016 output. You can enable all the special function typesetting rules with the Typesetting:-EnableTypesetRule command; see the help page for further details. You can also enable or disable specific typesetting rules using the Typesetting Rules Assistant.

• 

The usedot and useprime settings, as described on the Typesetting:-Settings help page, still control the parsing of dot and prime derivatives, but no longer the display. Instead, two new settings, typesetdot and typesetprime, have been added so that you can control the display independently. These are set to false by default and can also be adjusted using the Typesetting Rules Assistant.

MapleCloud Palette

The MapleCloud palette has been turned off by default. The new MapleCloud window is now the default way of interacting with content stored in the MapleCloud.

• 

To open the MapleCloud window, to go Tools>MapleCloud or, from the main toolbar, click the cloud icon ( ), and then click on one of the options Featured, Packages, or Updates.

• 

To open a document or package workbook from the MapleCloud, open it directly from the MapleCloud window or go to File>Open from Cloud.

• 

To save a document or package workbook to the MapleCloud, go to File>Save To Cloud.

• 

Additional settings including Group Management and Network Settings can be found under the MapleCloud toolbar icon, under the Cloud Settings submenu ( ).

To turn the the MapleCloud palette back on, see Arranging Palettes.

The hypergeometric function

In Maple 2017, when the hypergeometric function, represented by hypergeom, has a non-positive integer in the first list of parameters and the same non-positive integer in the second list of parameters, a) the function is simplified to a polynomial by simplify, the polynomial formed with the first terms of the hypergeometric series until the series truncates when the pochhammer function in the numerator becomes zero (related to having a non-positive integer argument); b) these parameters are not automatically canceled anymore as in previous releases, so that the information about the polynomial character of the function is not lost; c) when the other arguments are numerical the function is numerically evaluated as that polynomial by evalf.

Number Theory

The numtheory package has been deprecated.  Use the superseding package NumberTheory instead.

GraphTheory Graphs

The GraphTheory:-DrawGraph command uses a new grayscale colorscheme by default.  You can use the graph drawing setting from previous versions of Maple by specifying stylesheet="legacy".

IntegerRelations

The IntegerRelations:-LinearDependency now uses the LLL algorithm by default for inputs containing non-real numbers.

Importing from Excel

The ExcelTools:-Import command now returns a Matrix instead of an Array.

The plottools:-semitorus Command

The default value of the capped option in the plottools:-semitorus command is now false instead of true.

The convert/units Command

The convert command with the units option accepts two different calling sequences. Before Maple 2017, it also accepted a mix between these calling sequences. In essentially all cases, this indicated a mistake on behalf of the user, and as a consequence, the value returned did not make sense. In Maple 2017, an error is displayed if this situation occurs.

Change of Error Message When Accessing Nonexistent Record Fields

When accessing a nonexistent field, f, of a record, previous versions of Maple would raise the exception, "module does not export `f`". As of Maple 2017, this has been changed to "record does not have field `f`". This change is only a compatibility issue for code that uses a catch clause (see try) to catch such an exception, in which case the <catchString> will need to be updated.

Change in Code Edit Region Properties

In previous versions of Maple, the visible property of a Code Edit Region controlled whether the Code Edit Region was expanded or collapsed.  As of Maple 2017, this has changed.  Now the expanded property controls whether the Code Edit Region is expanded and the visible property controls whether the component is visible or hidden.  This is consistent with other embedded components.

Supported Video File Formats

• 

The Video Player Component now supports MP4 files.

• 

There is limited support for FLV and MP3 file formats, though these have not been fully tested by Maplesoft.  A list of video play file formats and associated codecs can be found here: https://docs.oracle.com/javafx/2/api/javafx/scene/media/package-summary.html#SupportedMediaTypes.

• 

The OGG and OGV file formats are no longer supported.

Pasting Windows Filenames into Worksheets

Windows filenames use backslashes as directory separators. In previous versions of Maple, when a Windows filename was pasted into a command in a worksheet, the backslashes had to be manually replaced with either a forward slash or two backslashes.

As of Maple 2017, backslashes are automatically replaced with forward slashes when you paste a valid Windows filename into a command in worksheet. A filename is valid if the file it refers to exists. For more information, see Files and Filenames.