Interface - Maple Programming Help

Online Help

All Products    Maple    MapleSim


Home : Support : Online Help : System : Information : Updates : Maple 2017 : updates/Maple2017/Interface

Interface

 

Improvements to Equation Editing

New MapleCloud Access from Toolbar

Equation Label Improvements

Context Menu Updates

Menu Updates

New Shortcut Keys

Default Options

Improvements to Equation Editing

To avoid common errors in entering expressions in 2-D math, Maple 2017 automatically inserts an explicit multiplication symbol in certain cases.  For example, if you write f+g x+y with a space between the parts, Maple replaces the implicit multiplication (the space) with a visible multiplication symbol (⋅).

This makes it clear that the space is interpreted as multiplication. This change is designed to help you avoid common errors in writing expressions and troubleshoot your work more quickly.

If you did not mean multiplication (instead you meant to apply the functions f+g to x+y), write the expression with adjacent parentheses.

Multiplication:

f+gx+y

f+gx+y

(1.1)

Function application: (no space)

f+gx+y

fx+y+gx+y

(1.2)

 

Expression in 2-D math

Meaning

(expr1)(expr2)

with no space between the closing and opening parenthesis

function application

(expr1) (expr2) 

with a space

The space means multiplication and to clarify that, Maple replaces the space with an explicit multiplication symbol.

You can control this feature. For details, see the Convert Space to Explicit Multiplication Operator section of the Options dialog.

New MapleCloud Access from Toolbar

You can now access the MapleCloud right from the worksheet toolbar.  Click the cloud icon ( ).  From here, log in, browse shared content, or check for updates on packages you've downloaded from the MapleCloud.

For more information, see Packages in the MapleCloud.

Equation Label Improvements

You can now insert a sequence or range of equation labels in one easy step using the equation label dialog.  See Using Equation Labels.

Context Menu Updates

Many more operations are now available in the context menu, including signal processing options and new curve fitting options are available for two-column matrices and data frames.

Examples:

Menu Updates

There are some new and updated items in Maple menus. Some of the changes are highlighted here.

Edit Menu

Two new menu items to Provide Workbook Password and Set/Reset Workbook Password.  See Password Protected Content.

View Menu

The View > Zoom Factor submenu now includes Zoom In and Zoom Out.

The View > Workbook Navigator submenu now includes Numbering.  See File Numbering in the Workbook Navigator.

Tools Menu

New menu item to MapleCloud provides access the new interface to the MapleCloud, similar to the cloud icon on the toolbar.  See Packages in the MapleCloud.

New Shortcut Keys

Several new shortcut keys have been added to Maple 2017 for interface zooming:

• 

Zoom In  

– 

Alt+Plus or Alt+=, Windows and Linux

– 

Control+Shift+=, Mac

• 

Zoom Out

– 

Alt+Minus, Windows and Linux

– 

Control+Minus or Control+Shift+Minus, Mac

A new shortcut key gives quick access to the help search box in the toolbar:

– 

Alt+S, Windows and Linux

– 

Control+S, Mac

 

For more comprehensive shortcut key lists by platform, see lists for Windows, Mac, and Linux.

Default Options

The Multiple Help Navigators option has been turned on by default. This means that any hyperlink in the help browser can be opened in a new help window. To open a link in a new window, right-click (Control-click, on Mac) the hyperlink and choose Open in New Window.

 

This option has also been removed from the Options dialog.