What's New in MapleSim 6.2 - MapleSim Help

Online Help

All Products    Maple    MapleSim


Home : Support : Online Help : MapleSim : Previous Releases : MapleSim 6.2 : What's New in MapleSim 6.2

MapleSim What's New

 

What's New in MapleSim 6.2

What's New in MapleSim 6.3

What's New in MapleSim 6.2

MapleSim 6.2 provides numerous enhancements to support every stage of development, from building the initial model to simulation, analysis, and deployment.

Model Building Enhancements

Easier Connections

Building models has been enhanced by making it easier to connect components to your model.

Dragging and dropping components on a line

You can now drag a component on to a straight line to automatically insert the component. To do this, select the component you want to add to your model, and then drag it onto the line. When the ports of the component are properly placed, they are highlighted, and the component will be placed inline.

 

Connecting to unattached lines

In previous versions of MapleSim, you could not connect to an unattached line. In MapleSim 6.2 you can now connect from one unattached line to another unattached line as well as from a port to an unattached line.

To connect an unattached line to another unattached line, highlight one of the unattached lines, and then drag your pointer to the second unattached line.

 

Similarly, to connect from a port to an unattached line, highlight the port, and then drag your pointer to the unattached line.

 

These enhancements make building and updating your models easier and more intuitive.

 

For more information, see Connecting Components in the Model Workspace.

More Intuitive Line Routing

Line routing has been improved to make it more intuitive. In previous versions of MapleSim, the rerouting algorithm ran every time a change was made to your model. For example, if you moved a single component in your diagram the rerouting algorithm would automatically run and possibly redraw all of the connections in your diagram. This behavior has been changed so that minimal wire routing changes are made when moving connected components. Specifically, the following features have been implemented.

• 

When you move a connected component, the connections to the selected component are rerouted only if they have to be. Previously, all the connections attached to the component would automatically be rerouted, which could lead to changes in your diagram that you were not expecting.

• 

When you make a copy of a model diagram (or part of a model diagram), the copy will have the same routing as the original. Previously, the rerouting algorithm ran on the copy and this often resulted in a copy that looked different from the original.

• 

If Snap to Grid is selected, lines created when you connect one component to another will snap to the grid. Also, when you reroute connections the rerouting algorithm will try its best to place lines on the grid.

• 

A new hot-key combination for rerouting connections has been assigned: Ctrl+D (Command+D for Macintosh®).

• 

You can reroute a portion of your diagram while leaving the rest untouched by first selecting the portion of the diagram to be rerouted, and then select Edit > Reroute Connections or press Ctrl+D (Command+D for Macintosh). To reroute the entire diagram, select it using the mouse or pressing Ctrl+A (Command+A for Macintosh). Note that this is a change from previous versions of MapleSim.

 

For more information, see Rerouting Connection Lines.

Improved Model Diagram Scaling

Two Zoom options have been added to help you visualize your model: scale to fit and reset zoom.

• 

Scale to fit: Allows you to resize your model so that it fits in the Model Workspace. To use the scale to fit option, either select View > Scale to fit from the menu bar or press Ctrl+T (Command+T for Macintosh).

• 

Reset Zoom: Allows you to return the view to the default zoom factor (100%). To reset the zoom factor, select View > Reset Zoom. You can also press Ctrl+0 (zero) for Windows® and Linux®; on Macintosh, press Command+0 (zero).

 

For more information, see Changing the Zoom Level for the Model Diagram.

API Updates

The MapleSim Application Programming Interface (API) includes new functionality for the SetComponent command and the new Linearize command.

SetComponent

The previous version of the SetComponent command created a component from Modelica source. The new version allows you to create a component from a DynamicSystems object as well as from Modelica source.

 

For more information, see MapleSim[LinkModel][SetComponent] and DynamicSystems.

Linearize

The Linearize command is optimized to work on a linked MapleSim subsystem and returns the linearized form of the linked subsystem as a DynamicSystems object. The returned DynamicSystems object can then be analyzed in Maple and then returned back to MapleSim as a component using the SetComponent command.

 

For more information, see MapleSim[LinkModel][Linearize], DynamicSystems, and MapleSim[LinkModel][SetComponent].

Better Parameter Handling

You can now edit the parameters table and manage it more easily in MapleSim 6.2. Specifically, we have added the ability to change the ordering of the parameters and made it easier to delete unwanted parameters.

Reordering parameters

To reorder your parameters, place your pointer over the Drag icon ( ) for the parameter that you want to move, and then drag your pointer to the desired row.

 

Deleting a parameter

In previous versions of MapleSim, the only way to delete an unwanted parameter was to delete the Name entry for the parameter from the parameters table. This was cumbersome and not always obvious. To make the deletion of parameters easier, a new column with a Delete icon ( ) has been added to the parameters table. To delete a parameter, click the Delete icon for the particular parameter.

Mass and Inertia for CAD Geometry Components

In addition to helping you visualize your model, the CAD Geometry component can now take into account physical quantities such as mass and inertia during the simulation process.

A new parameter for the density (ρ) is now found under the Inspector tab for the CAD Geometry component. When you provide a value for the density, MapleSim uses this value and the information in the .stl file to calculate the volume, mass, and inertia of the rigid body. The mass and inertia are then taken into account during the simulation process to give you a truer representation of how your model behaves.

You will still be able to open older models that use a previous version of the CAD Geometry component. When you open a model with a previous version of the CAD Geometry component, the density parameter is given the default value of zero.

Updated Modelica Code View

The Code View in MapleSim displays the Modelica® code for your model. Updates to the Code View make it easier to read and work with the Modelica code for your model. The following options are now available in the Code View.

• 

Annotations: select Annotations to show annotations in the Code View window.

• 

Collapse Annotations: if Annotations are shown, select Collapse Annotations to collapse them.

• 

Line Wrap: select Line Wrap to have lines wrap to a new line when they reach the end of the Code View window.

• 

Line Numbers: select Line Numbers to show line numbers in the Code View window.

To access the Code View, click Code ( ) in the Navigation Toolbar.

MapleSim Hydraulics Library® from Modelon

Maplesoft has formed a technology partnership with Modelon, a renowned developer of high-quality Modelica libraries, to provide industry-tested hydraulics components within the system-level modeling environment of MapleSim. With the MapleSim Hydraulics Library from Modelon, available as a separate add-on component library, you can seamlessly incorporate advanced hydraulics components into your MapleSim models while continuing to take full advantage of all the modeling, analysis, and simulation abilities of MapleSim.

 

With the MapleSim Hydraulics Library from Modelon you can:

• 

Choose from over 200 components for modeling pumps, motors, cylinders, restrictions, valves, hydraulic lines, lumped volumes, and sensors

• 

Incorporate compressible oils and cavitation effects into your models

• 

Select from a pre-defined list of standard hydraulics oils or define your own

• 

Easily reuse, customize, and extend components to suit your exact needs

Connectivity Improvements

Improvements have been made to many of the connectors that allow you to integrate MapleSim into your toolchain.

MapleSim Connector

Two new features have been added to the MapleSim Connector for connectivity with Simulink®: external lookup tables and feedthrough port designation.

• 

External lookup tables: A new option has been added to the S-Functions Options section in the Simulink® Component Block Generation Template: Export lookup tables as external .CSV files. When selected, this option exports the parameters for your model to a file that your compiled code reads at runtime. This allows you to change your parameters without having to recompile your model for each new scenario.

• 

Feedthrough port designation: In previous versions of the MapleSim Connector, all inputs were labeled as feedthrough in the S-Functions. That is, it was assumed that the outputs depended on every input to the system. The MapleSim Connector now designates all input ports that do not effect the outputs as non-feedthrough. This can help Simulink® solve algebraic loops more effectively.

MapleSim Connector for FMI

The FMU Generation template has a new option that allows you to select the embedded fixed-step solver for co-simulation: Embedded Solver for Co-Simulation. In the previous version of the template the Euler fixed-solver was always used. With this version you can choose from one of the following fixed-step solvers: Euler, RK2, RK3, RK4, and Implicit Euler.

MapleSim Connector for JMAG®-RT

Five new components have been added to simulate motors designed in JMAG-RT. The components have been divided into two categories: rotational motors and translational motors.

The new rotational motor components are:

• 

Permanent Magnet Synchronous Motor: a permanent-magnet, three-phase, synchronous electric motor.

• 

Stepper Motor: a two-phase stepper motor.

• 

Switched Reluctance Motor: a multiphase switched-reluctance stepper motor.

The new translational motor components are:

• 

Linear Synchronous Motor: a three-phase, linear synchronous electric motor.

• 

Solenoid: a single-phase, linear solenoid.

These components replace the Generic JMAG-RT motor component from the previous version of this connector.

MapleSim Connector for VI-CarRealTime

The VI-CarRealTime Plugin Solver Generation template has been updated to give you more options for your plugin solver code. The new options allow you to tailor the plugin solver for your version of VI-CarRealTime. The new options are:

• 

VI-CarRealTime version: Select the version of VI-CarRealTime that you are using.

• 

Target binary: Select the platform (32-bit or 64-bit) for the version of VI-CarRealTime that you have.

What's New in MapleSim 6.3

MapleSim 6.3 contains significant enhancements to the simulation engine in MapleSim.

• 

For all models, the symbolic pre-processing time prior to simulation has been reduced, so the numerical simulation phase will begin sooner. This improvement is especially significant for models that include Modelica-based custom components defined using functions and algorithms.

• 

Simulations of models that use the MapleSim Hydraulics Library from Modelon run significantly faster due to a dramatic improvement in the pre-processing time for these models.

• 

Code generation for all target platforms has been improved so that more model parameters are modifiable when the simulation is run outside of MapleSim.

• 

Support for Modelica-based custom components has been expanded so that a wider class of functions can now be included in the component definition.

 

Simulink is a registered trademark of The MathWorks, Inc. JMAG is a registered trademark by JSOL Corp. in the US and other countries. Modelica is a registered trademark of the Modelica Association. VI-CarRealTime is a trademark of of VI-grade GmbH. Hydraulics Library is a registered trademark of Modelon AB. Linux is a registered trademark of Linus Torvalds. Macintosh is a registered trademark of Apple Computer, Inc. Windows is a registered trademark of Microsoft Corporation.